Glitches in 1.10.2-v1.0 and 1.10.4-v1.0

  • July 19, 2018 at 11:51 am #1836
    stevland
    Keymaster

    If you installed either 

    osTicket-Awesome-1.10.2-v1.0
    or
    osTicket-Awesome-1.10.4-v1.0

    on or before July 18th and you are experiencing some page loading issues in the Admin Panel including Theme page not fully loading

    Please do one of the following to fix the glitch:

    1) Replace /scp/js/scp.js with this file file

    OR

    2) Open /scp/js/scp.js in a text editor and comment out lines 1056 – 1073 so it looks like this:

    // Enable PJAX for the staff interface - breaks osta
    // if ($.support.pjax) {
    // $(document).on('click', 'a', function(event) {
    // var $this = $(this);
    // if (!$this.hasClass('no-pjax')
    // && !$this.closest('.no-pjax').length
    // && $this.attr('href').charAt(0) != '#')
    // $.pjax.click(event, {container: $this.data('pjaxContainer') || $('#pjax-container'), timeout: 2000});
    // })
    // }
    //
    // $(document).on('click', '.link:not(a):not(.button)', function(event) {
    // var $e = $(event.currentTarget);
    // $('<a>').attr({href: $e.attr('href'), 'class': $e.attr('class')})
    // .hide()
    // .insertBefore($e)
    // .get(0).click(event);
    // });

     

    • This topic was modified 6 months ago by stevland.
  • August 15, 2018 at 1:42 am #2062
    kivuonline
    Participant

    Update: Fixed. Permission issues.

    We are unable to make custom theme colour selections. It’s only the preset combinations that can be applied. Otherwise this is a job well done. Thanks.

    osTicket v1.10.1 // osTicket-Awesome-1.10.1-v1.4 

    The current version is osTicket-Awesome-1.10.4-v1.0

    • This reply was modified 5 months ago by kivuonline.
    • This reply was modified 5 months ago by kivuonline.
  • December 27, 2018 at 2:05 am #2722
    lucn
    Participant

    When using the Knowledgebase; when there is an artikel with attachment the client user ( with login) can’t see the alltachment. Agents can!

    i’ve installed awsome theme 1.10.4

    When using the standard osticket theme the attachment is visible so i guess it has something to do with the theme.

     

    • January 9, 2019 at 9:45 am #2771
      stevland
      Keymaster

      @lucn,

      Thank you for reporting this. Working on a fix.

  • January 15, 2019 at 2:30 pm #2792
    lucn
    Participant

    @stevland,

     

    Any idea how long this would take before fix?

    thanks,

You must be logged in to reply to this topic.

Topic Tags