[Resolved] Help asap with 403 Forbidden

  • May 22, 2020 at 10:13 pm #5836
    R
    Randy Jonathan
    Participant

    I upgraded to 1.14.2 Os and it worked very well

    I then decided to installed the awesome upgrade 1.14.2 and now I get 

    Forbidden
    You don’t have permission to access this resource.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

  • May 22, 2020 at 11:03 pm #5837
    stevland
    Keymaster

    403 Forbidden isn’t a typical error that I’m used to people reporting. Unfortunately it doesn’t immediately suggest a particular issue.

    First off, make sure you reset your browser cache after any upgrade.

    Reset Permissions

    osTicket Awesome uses standard permissions.

    All folders should be 755 (drwxr-xr-x) and all files should be 644 (-rw-r–r–).

    If you suspect that your permissions are messed up you can easily reset them.

    For directories

    # find . -type d -print0 | xargs -0 chmod 0755

    For files

    # find . -type f -print0 | xargs -0 chmod 0644

    Check Error Logs

    Error 403 is a generic message. When you see that error in your web browser, the actual error message has been recorded in your Apache logs. (If you don’t know how to find your Apache logs, ask your web host).

    Look for the error that occurs at the exact time that you try to load the page.

    Once you find the actual error, feel free to post it here (although you may want to redact any IP addresses or confidential server information)..

  • May 24, 2020 at 6:07 am #5849
    R
    Randy Jonathan
    Participant

    Thank you for the quick reply. I had a feeling it was server related. I decided to put the original osticket back online and it worked. At that point I knew it was related to files and not the server. After wasting 6 hours trying to figure out why it wouldn’t work and multiple uploads, it turns out not all the files were extracted correctly from the awesome zip file. I was so upset that something so simple caused me a day of headache.  Again TY for the quick support. 

  • May 24, 2020 at 10:21 am #5851
    stevland
    Keymaster

    Yikes! I’ve definitely had days like that. 🙁

    Thanks for reporting back, Randy. I’ll have to add that to my list of potential issues.

  • May 24, 2020 at 10:28 am #5852
    R
    Randy Jonathan
    Participant

    I don’t think it is your fault, but you do have a zip inside a zip. 

    I navigated to the second zip only, I think it was the upload folder. I really didn’t think that would cause an issue.

You must be logged in to reply to this topic.

Topic Tags