[Resolved] Prevent auto scroll when opening tickets

  • August 26, 2020 at 7:31 pm #6270
    N
    NIcholasjansen
    Participant

    Hi there,

    I was wondering if there is any easy way to prevent (or change) the way tickets auto scroll when you click on them. 

    We use our tickets with a lot of internal fields and every time one is updated it scrolls to the bottom of the ticket.

    I understand this is less of a theme thing so may not be possible – just prefer to use osTicket awesome before I do source code edits 🙂

  • August 27, 2020 at 9:23 am #6274
    stevland
    Keymaster

    @nicholasjansen,

    As you probably realize, this is more of an osTicket question, rather than an osTicket Awesome question.

    In any event, the easiest way to do this is with an edit to the source code.

    Open /scp/js/thread.js and change line 20 from 

    scrollTo: function (entry) {

    to

    scrollTo: function (entry) { return;

    Of course, the above mod would require that you reapply it any time you upgrade.

    The only other option I am aware of is to install both the Attachment Preview plugin and the Prevent Autoscroll plugin.

  • December 21, 2020 at 2:44 pm #7191
    N
    NIcholasjansen
    Participant

    Hey @stevland

    I recently updated all my systems and went to use this fix, however it doesn’t seem to be working now. Any new ideas? I can try the plugins but I much prefered your code tweak 🙂

  • December 27, 2020 at 9:55 am #7196
    kkrumm
    Participant

    It does work perfectly. Have you tried clearing your browser cache? 

  • January 21, 2021 at 12:04 pm #7272
    stevland
    Keymaster

    Nope, sorry those are my only suggestions.

    But again, this is actually an osTicket question. By asking it here you on have the potential of receiving a small fraction of the suggestions that you might receive if you asked in the osTicket Mods and Customizations forum.

  • February 18, 2022 at 7:26 am #9438

    Wanted to bump this as still good today in 2022. Only added the part in yellow at the end and it worked immediately.

You must be logged in to reply to this topic.

Topic Tags