[Resolved] User frontend is not working properly

    • April 13, 2023 at 8:24 am #16149


      the user frontend is not working properly for us.
      Unfortunately I can’t tell since which version this is the case but these are the main issues I am facing right now:

      1. Form fields do not load properly after you select a help topic
      2. Dropdown select fields are not displayed properly


      I will try to upload videos where you can see the exact issues in a reply.
      I just tried to do so in the main message here which resulted in loosing all the text I wrote as apparently some issue occured.


      Thanks and best regards

    • April 13, 2023 at 8:51 am #16160

      Did I break the forum now?

      My previous reply vanished after I tried to edit it and now I can not post any new replies anymore.

      Edit: OK, this worked now.
      Maybe links to external sites get blocked?

    • April 13, 2023 at 8:58 am #16167

      I can not manage to include a video or a link to our cloud.
      Can I instead email this to some support address maybe?

    • April 17, 2023 at 8:34 am #16254

      We ran into the same issue.  The screen is referencing the incorrect jquery version.  You can temporarily hit f12 on the screen to get into developer mode and see the 2 404 errors for jquery.  Go into the js folder and make copies of the query files and rename the copies to match the 404 error names.

    • April 27, 2023 at 2:32 pm #16547

      Hi bmerz,

      thank you.
      I fixed it like that now.

      I am really surprised that such a big bug is in the latest release and especially that it was still not fixed with an update.


      Best regards

    • April 28, 2023 at 7:57 am #16573

      Make the file version changes in upload/include/client/header.inc.php

      The version in the file names being called just need to be changed on line 58 and 59

      <script type=”text/javascript” src=”<?php echo ROOT_PATH; ?>js/jquery-3.5.1.min.js?ca95150″></script>
      <script type=”text/javascript” src=”<?php echo ROOT_PATH; ?>js/jquery-ui-1.13.1.custom.min.js?ca95150″></script>


      <script type=”text/javascript” src=”<?php echo ROOT_PATH; ?>js/jquery-3.6.3.min.js?ca95150″></script>
      <script type=”text/javascript” src=”<?php echo ROOT_PATH; ?>js/jquery-ui-1.13.2.custom.min.js?ca95150″></script>

    • April 28, 2023 at 11:41 am #16598

      Hi guys, 

      I’m sorry that I’ve been unavailable for a while.

      And I agree, this is a terrible mistake.

      I’m really pleased that you managed to work out your own solution.

      For anyone else that is reading this, upgrade to the latest hotfix (osTicket-1.17.3-Awesome-102) or (recommended) simply open /include/client/header.inc.php and replace its contents with this code.

You must be logged in to reply to this topic.